Issue with customer login (Azure AD)

Incident Report for Safe Sky Industries

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 04:48 UTC

Monitoring

We have implemented a workaround to enable logins during the Azure outage. During the workaround, the domain name "safeskyb2c.b2clogin.com" will be visible during login. This is legitimate and expected.
Posted Oct 29, 2025 - 19:12 UTC

Identified

Azure are reporting issues with network infrastructure globally; we are actively monitoring the situation.
Posted Oct 29, 2025 - 18:00 UTC

Update

Our identity provider Azure AD is currently experiencing an outage that affects logins to the Airside Sync platform. We are continuing to investigate this issue.
Posted Oct 29, 2025 - 15:54 UTC

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 15:53 UTC
This incident affected: Auxiliary Sites (Azure AD Authentication).