Android app login problems

Incident Report for Safe Sky Industries

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 13:59 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 17, 2025 - 12:42 UTC

Monitoring

The Android app version 1.26.1 is released to the Google Play Store.
Posted Feb 17, 2025 - 12:11 UTC

Identified

The issue has been identified and a fix is being implemented. A new Android app version 1.26.1 is currently being released.
Posted Feb 17, 2025 - 12:00 UTC

Update

Android users on the latest app version 1.26.0 may currently experience problems logging in. We are currently investigating this issue.
Posted Feb 17, 2025 - 11:44 UTC

Investigating

We are currently investigating this issue.
Posted Feb 17, 2025 - 11:42 UTC
This incident affected: Service (App, Web & API) (West Europe).